×

Freeje for Android

 

Install
×

Freeje for iPhone and iPad

 

Install

 

To start using Virtual SIM you will need the following:

1. Android smartphone with Android 2.3 or higher, or iOS device with iOS 7 or higher;

2. USB-modems with voice calls support;

3. PC with Windows 7 OS or higher and .Net Framework 3.5 installed.

  

Back